{"action":"Upgrade tomcat10 to 10.1.6-1+deb12u2 or later.","affected":[{"fixed":"10.1.6-1+deb12u2","introduced":"0"}],"component":"tomcat10","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["10.1.6-1+deb12u2"],"id":"tcs_01M5NJBWFYN21PSR5ZQXT97CN7","modified_at":"2026-10-26T18:01:28.178486625Z","published_at":"2023-11-28T16:15:06.943Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-46589","https://security-tracker.debian.org/tracker/CVE-2023-46589"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-46589","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-46589"}],"summary":"Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not co"}