{"action":"Upgrade nats-server to 2.10.3-1 or later.","affected":[{"fixed":"2.10.3-1","introduced":"0"}],"component":"nats-server","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.10.3-1"],"id":"tcs_01M5NJC7ZJWENKTMRM9SPA4A6P","modified_at":"2026-10-26T18:02:01.265627314Z","published_at":"2023-10-30T17:15:52.467Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-47090","https://security-tracker.debian.org/tracker/CVE-2023-47090"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-47090#Debian:13/nats-server","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-47090"}],"summary":"NATS nats-server before 2.9.23 and 2.10.x before 2.10.2 has an authentication bypass. An implicit $G user in an authorization block can sometimes be used for unauthenticated access, even when the inte"}