{"action":"Upgrade php-phpseclib3 to 3.0.19-1+deb12u1 or later.","affected":[{"fixed":"3.0.19-1+deb12u1","introduced":"0"}],"component":"php-phpseclib3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.0.19-1+deb12u1"],"id":"tcs_01M5NJDG46D5TJ5Q868WXTR7PY","modified_at":"2026-10-26T18:02:50.160265131Z","published_at":"2023-11-27T18:15:07.537Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-49316","https://security-tracker.debian.org/tracker/CVE-2023-49316"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-49316","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-49316"}],"summary":"In Math/BinaryField.php in phpseclib 3 before 3.0.34, excessively large degrees can lead to a denial of service."}