{"action":"Upgrade pillow to 10.2.0-1 or later.","affected":[{"fixed":"10.2.0-1","introduced":"0"}],"component":"pillow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["10.2.0-1"],"id":"tcs_01M5NJE3VHM2PF734BCSMR91TZ","modified_at":"2026-10-26T18:02:42.492656970Z","published_at":"2024-01-19T20:15:11.870Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-50447","https://security-tracker.debian.org/tracker/CVE-2023-50447"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-50447#Debian:14/pillow","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-50447"}],"summary":"Pillow through 10.1.0 allows PIL.ImageMath.eval Arbitrary Code Execution via the environment parameter, a different vulnerability than CVE-2022-22817 (which was about the expression parameter)."}