{"action":"Upgrade wolfssl to 5.6.6-1.2 or later.","affected":[{"fixed":"5.6.6-1.2","introduced":"0"}],"component":"wolfssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.6.6-1.2"],"id":"tcs_01M5NJZXG94F6SXCM18J3RDYDS","modified_at":"2026-10-26T18:01:31.722335920Z","published_at":"2024-02-20T22:15:08.197Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-6936","https://security-tracker.debian.org/tracker/CVE-2023-6936"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-6936#Debian:13/wolfssl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-6936"}],"summary":"In wolfSSL prior to 5.6.6, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS client or network attacker can trigger a buffer over-read on the heap of 5 bytes (WO"}