{"action":"Upgrade libmodule-scandeps-perl to 1.35-2 or later.","affected":[{"fixed":"1.35-2","introduced":"0"}],"component":"libmodule-scandeps-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.35-2"],"id":"tcs_01M5NK17MWZECTMEPZVHXJV97K","modified_at":"2026-09-15T09:02:58.974477389Z","published_at":"2024-11-19T18:15:19.773Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-10224","https://security-tracker.debian.org/tracker/CVE-2024-10224"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-10224#Debian:13/libmodule-scandeps-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-10224"}],"summary":"Qualys discovered that if unsanitized input was used with the library Modules::ScanDeps, before version 1.36 a local attacker could possibly execute arbitrary shell commands by open()ing a \"pesky pipe"}