{"action":"Upgrade needrestart to 3.7-3.1 or later.","affected":[{"fixed":"3.7-3.1","introduced":"0"}],"component":"needrestart","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.7-3.1"],"id":"tcs_01M5NK1NFY00PCEA1JBFAPC6NT","modified_at":"2026-09-15T09:02:58.635392454Z","published_at":"2024-11-19T18:15:19.973Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-11003","https://security-tracker.debian.org/tracker/CVE-2024-11003"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-11003#Debian:14/needrestart","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-11003"}],"summary":"Qualys discovered that needrestart, before version 3.8, passes unsanitized data to a library (Modules::ScanDeps) which expects safe input. This could allow a local attacker to execute arbitrary shell"}