{"action":"Upgrade black to 24.4.0-1 or later.","affected":[{"fixed":"24.4.0-1","introduced":"0"}],"component":"black","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["24.4.0-1"],"id":"tcs_01M5NK3M7XM6PVJ44SQBR9KCSC","modified_at":"2026-09-15T09:02:59.077069255Z","published_at":"2024-03-19T05:15:09.447Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-21503","https://security-tracker.debian.org/tracker/CVE-2024-21503"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-21503#Debian:13/black","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-21503"}],"summary":"Versions of the package black before 24.3.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the lines_with_leading_tabs_expanded function in the strings.py file. An attacker could e"}