{"action":"Upgrade djangorestframework to 3.15.2-1 or later.","affected":[{"fixed":"3.15.2-1","introduced":"0"}],"component":"djangorestframework","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.15.2-1"],"id":"tcs_01M5NK3NC82NC6VCMPFXZSAYTD","modified_at":"2026-09-15T09:02:59.016560610Z","published_at":"2024-06-26T05:15:50.093Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-21520","https://security-tracker.debian.org/tracker/CVE-2024-21520"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-21520#Debian:14/djangorestframework","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-21520"}],"summary":"Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting an"}