{"action":"Upgrade node-markdown-to-jsx to 7.2.0+dfsg-3 or later.","affected":[{"fixed":"7.2.0+dfsg-3","introduced":"0"}],"component":"node-markdown-to-jsx","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["7.2.0+dfsg-3"],"id":"tcs_01M5NK3NG5CE5069T4GAMNZ726","modified_at":"2026-09-15T09:02:59.079581552Z","published_at":"2024-10-15T05:15:11.530Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-21535","https://security-tracker.debian.org/tracker/CVE-2024-21535"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-21535","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-21535"}],"summary":"Versions of the package markdown-to-jsx before 7.4.0 are vulnerable to Cross-site Scripting (XSS) via the src property due to improper input sanitization. An attacker can execute arbitrary code by inj"}