{"action":"Upgrade puma to 6.4.2-1 or later.","affected":[{"fixed":"6.4.2-1","introduced":"0"}],"component":"puma","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["6.4.2-1"],"id":"tcs_01M5NK3QEWGSJB9RPBH8FY47W6","modified_at":"2026-09-15T09:02:59.083307055Z","published_at":"2024-01-08T14:15:47.640Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-21647","https://security-tracker.debian.org/tracker/CVE-2024-21647"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-21647#Debian:14/puma","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-21647"}],"summary":"Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTT"}