{"action":"Upgrade ruby-commonmarker to 0.23.4-1 or later.","affected":[{"fixed":"0.23.4-1","introduced":"0"}],"component":"ruby-commonmarker","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.23.4-1"],"id":"tcs_01M5NK42ZM6FZVFP46RHN2A0PS","modified_at":"2026-09-15T09:02:59.142124214Z","published_at":"2024-01-04T21:15:10.173Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-22051","https://security-tracker.debian.org/tracker/CVE-2024-22051"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-22051#Debian:14/ruby-commonmarker","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-22051"}],"summary":"CommonMarker versions prior to 0.23.4 are at risk of an integer overflow vulnerability. This vulnerability can result in possibly unauthenticated remote attackers to cause heap memory corruption, pote"}