{"action":"Upgrade luajit to 2.1.0~beta3+git20220320+dfsg-4.1+deb12u1 or later.","affected":[{"fixed":"2.1.0~beta3+git20220320+dfsg-4.1+deb12u1","introduced":"0"}],"component":"luajit","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.1.0~beta3+git20220320+dfsg-4.1+deb12u1"],"id":"tcs_01M5NK5VP1EWJPCG1JH2RJ03QJ","modified_at":"2026-09-15T09:03:00.971647448Z","published_at":"2025-07-07T17:15:27.247Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-25176","https://security-tracker.debian.org/tracker/CVE-2024-25176"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-25176","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-25176"}],"summary":"LuaJIT through 2.1 and OpenRusty luajit2 before v2.1-20240626 have a stack-buffer-overflow in lj_strfmt_wfnum in lj_strfmt_num.c."}