{"action":"Upgrade luajit to 2.1.0+openresty20240314-1 or later.","affected":[{"fixed":"2.1.0+openresty20240314-1","introduced":"0"}],"component":"luajit","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.1.0+openresty20240314-1"],"id":"tcs_01M5NK5WFX3DTFRZC9PC9SKHJV","modified_at":"2026-09-15T09:02:59.544719428Z","published_at":"2025-07-07T17:15:27.527Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-25178","https://security-tracker.debian.org/tracker/CVE-2024-25178"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-25178#Debian:13/luajit","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-25178"}],"summary":"LuaJIT through 2.1 and OpenRusty luajit2 before v2.1-20240314 have an out-of-bounds read in the stack-overflow handler in lj_state.c."}