{"action":"Upgrade qtbase-opensource-src to 5.15.10+dfsg-7 or later.","affected":[{"fixed":"5.15.10+dfsg-7","introduced":"0"}],"component":"qtbase-opensource-src","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.15.10+dfsg-7"],"id":"tcs_01M5NK6219CD63YA91CHGG7SMZ","modified_at":"2026-09-15T09:03:01.334701704Z","published_at":"2024-03-27T03:15:12.007Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-25580","https://security-tracker.debian.org/tracker/CVE-2024-25580"],"severity":{"label":"medium","score":6.2},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-25580#Debian:13/qtbase-opensource-src","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-25580"}],"summary":"An issue was discovered in gui/util/qktxhandler.cpp in Qt before 5.15.17, 6.x before 6.2.12, 6.3.x through 6.5.x before 6.5.5, and 6.6.x before 6.6.2. A buffer overflow and application crash can occur"}