{"action":"Upgrade phpseclib to 1.0.20-1+deb12u2 or later.","affected":[{"fixed":"1.0.20-1+deb12u2","introduced":"0"}],"component":"phpseclib","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.0.20-1+deb12u2"],"id":"tcs_01M5NKCDC4R6HPGMH10TRXJ8DZ","modified_at":"2026-11-02T12:02:02.210341120Z","published_at":"2024-03-01T23:15:08.553Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-27355","https://security-tracker.debian.org/tracker/CVE-2024-27355"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-27355#Debian:12/phpseclib","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-27355"}],"summary":"An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that le"}