{"action":"Upgrade fastdds to 2.14.0+ds-2 or later.","affected":[{"fixed":"2.14.0+ds-2","introduced":"0"}],"component":"fastdds","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.14.0+ds-2"],"id":"tcs_01M5NKDATF8KTBJXB3AS0V7KAQ","modified_at":"2026-09-15T09:03:12.263167981Z","published_at":"2024-03-20T20:15:08.893Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-28231","https://security-tracker.debian.org/tracker/CVE-2024-28231"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-28231#Debian:13/fastdds","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-28231"}],"summary":"eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.14.0, 2.13.4, 2.12.3, 2.10.4, and 2.6.8, manipulated DATA Submes"}