{"action":"Upgrade commons-configuration2 to 2.10.1-1 or later.","affected":[{"fixed":"2.10.1-1","introduced":"0"}],"component":"commons-configuration2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.10.1-1"],"id":"tcs_01M5NKE07PYBCPSQ542S8WMQ3W","modified_at":"2026-09-15T09:03:06.584911340Z","published_at":"2024-03-21T09:15:07.807Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-29131","https://security-tracker.debian.org/tracker/CVE-2024-29131"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-29131#Debian:14/commons-configuration2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-29131"}],"summary":"Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1, which fix"}