{"action":"Upgrade hdf5 to 1.14.5+repack-1 or later.","affected":[{"fixed":"1.14.5+repack-1","introduced":"0"}],"component":"hdf5","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.14.5+repack-1"],"id":"tcs_01M5NKE2E4M2G4DE7F7ER6CSWA","modified_at":"2026-09-15T09:03:06.442629798Z","published_at":"2024-05-14T15:15:32.213Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-29160","https://security-tracker.debian.org/tracker/CVE-2024-29160"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-29160#Debian:13/hdf5","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-29160"}],"summary":"HDF5 through 1.14.3 contains a heap buffer overflow in H5HG__cache_heap_deserialize, resulting in the corruption of the instruction pointer and causing denial of service or potential code execution."}