{"action":"Upgrade hdf5 to 1.14.5+repack-1 or later.","affected":[{"fixed":"1.14.5+repack-1","introduced":"0"}],"component":"hdf5","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.14.5+repack-1"],"id":"tcs_01M5NKE3XCFGYJZAFZBYM923FH","modified_at":"2026-09-15T09:03:06.394228916Z","published_at":"2024-05-14T15:15:33.100Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-29164","https://security-tracker.debian.org/tracker/CVE-2024-29164"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-29164#Debian:13/hdf5","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-29164"}],"summary":"HDF5 through 1.14.3 contains a stack buffer overflow in H5R__decode_heap, resulting in the corruption of the instruction pointer and causing denial of service or potential code execution."}