{"action":"Upgrade node-ip to 2.0.1+~1.1.3-3 or later.","affected":[{"fixed":"2.0.1+~1.1.3-3","introduced":"0"}],"component":"node-ip","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.0.1+~1.1.3-3"],"id":"tcs_01M5NKE6DWY82TQB5MT5754D61","modified_at":"2026-11-02T12:02:30.219048448Z","published_at":"2024-05-27T20:15:08.970Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-29415","https://security-tracker.debian.org/tracker/CVE-2024-29415"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-29415#Debian:13/node-ip","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-29415"}],"summary":"The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally"}