{"action":"Upgrade ghostscript to 10.03.0~dfsg-1 or later.","affected":[{"fixed":"10.03.0~dfsg-1","introduced":"0"}],"component":"ghostscript","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["10.03.0~dfsg-1"],"id":"tcs_01M5NKE93CF13MN1X5N3YP4EBR","modified_at":"2026-09-15T09:03:18.735288403Z","published_at":"2024-07-03T18:15:04.973Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-29509","https://security-tracker.debian.org/tracker/CVE-2024-29509"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-29509#Debian:14/ghostscript","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-29509"}],"summary":"Artifex Ghostscript before 10.03.0 has a heap-based overflow when PDFPassword (e.g., for runpdf) has a \\000 byte in the middle."}