{"action":"Upgrade putty to 0.81-1 or later.","affected":[{"fixed":"0.81-1","introduced":"0"}],"component":"putty","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.81-1"],"id":"tcs_01M5NKF20P3ZJZTQ7N2AW0WEP1","modified_at":"2026-11-02T12:01:45.316031041Z","published_at":"2024-04-15T20:15:11.077Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-31497","https://security-tracker.debian.org/tracker/CVE-2024-31497"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-31497#Debian:13/putty","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-31497"}],"summary":"In PuTTY 0.68 through 0.80 before 0.81, biased ECDSA nonce generation allows an attacker to recover a user's NIST P-521 secret key via a quick attack in approximately 60 signatures. This is especially"}