{"action":"Upgrade hdf5 to 1.14.5+repack-1 or later.","affected":[{"fixed":"1.14.5+repack-1","introduced":"0"}],"component":"hdf5","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.14.5+repack-1"],"id":"tcs_01M5NKFTS4GTSE5R0BW46TY4NX","modified_at":"2026-09-15T09:03:02.566020538Z","published_at":"2024-05-14T15:36:46.893Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-32617","https://security-tracker.debian.org/tracker/CVE-2024-32617"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-32617#Debian:13/hdf5","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-32617"}],"summary":"HDF5 Library through 1.14.3 contains a heap-based buffer over-read caused by the unsafe use of strdup in H5MM_xstrdup in H5MM.c (called from H5G__ent_to_link in H5Glink.c)."}