{"action":"Upgrade freerdp3 to 3.5.1+dfsg1-1 or later.","affected":[{"fixed":"3.5.1+dfsg1-1","introduced":"0"}],"component":"freerdp3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.5.1+dfsg1-1"],"id":"tcs_01M5NKFZ155DPHBBYJ7E11D8X3","modified_at":"2026-11-02T12:02:07.828220417Z","published_at":"2024-04-23T20:15:07.407Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-32659","https://security-tracker.debian.org/tracker/CVE-2024-32659"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-32659#Debian:13/freerdp3","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-32659"}],"summary":"FreeRDP is a free implementation of the Remote Desktop Protocol. FreeRDP based clients prior to version 3.5.1 are vulnerable to out-of-bounds read if `((nWidth == 0) and (nHeight == 0))`. Version 3.5."}