{"action":"Upgrade cacti to 1.2.24+ds1-1+deb12u3 or later.","affected":[{"fixed":"1.2.24+ds1-1+deb12u3","introduced":"0"}],"component":"cacti","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.2.24+ds1-1+deb12u3"],"id":"tcs_01M5NKGFGTDX0RRP1AJNWS9ZX0","modified_at":"2026-09-15T09:03:02.698909144Z","published_at":"2024-05-14T15:38:39.517Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-34340","https://security-tracker.debian.org/tracker/CVE-2024-34340"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-34340","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-34340"}],"summary":"Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password"}