{"action":"Upgrade composer to 2.5.5-1+deb12u2 or later.","affected":[{"fixed":"2.5.5-1+deb12u2","introduced":"0"}],"component":"composer","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.5.5-1+deb12u2"],"id":"tcs_01M5NKGTPC421FC6R214QZQP63","modified_at":"2026-09-15T09:03:02.883755606Z","published_at":"2024-06-10T22:15:09.893Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-35242","https://security-tracker.debian.org/tracker/CVE-2024-35242"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-35242","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-35242"}],"summary":"Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch nam"}