{"action":"Upgrade libmodbus to 3.1.6-2.1 or later.","affected":[{"fixed":"3.1.6-2.1","introduced":"0"}],"component":"libmodbus","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.1.6-2.1"],"id":"tcs_01M5NKM7KGJC8ATZ0PVQ2GJRXP","modified_at":"2026-09-15T09:03:18.774653440Z","published_at":"2024-05-31T20:15:10.290Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-36843","https://security-tracker.debian.org/tracker/CVE-2024-36843"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-36843#Debian:14/libmodbus","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-36843"}],"summary":"libmodbus v3.1.6 was discovered to contain a heap overflow via the modbus_mapping_free() function."}