{"action":"Upgrade libmodbus to 3.1.6-2.1 or later.","affected":[{"fixed":"3.1.6-2.1","introduced":"0"}],"component":"libmodbus","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.1.6-2.1"],"id":"tcs_01M5NKM81G9Z8EQHP4FN8WBTYX","modified_at":"2026-09-15T09:03:05.926359093Z","published_at":"2024-05-31T20:15:10.380Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-36844","https://security-tracker.debian.org/tracker/CVE-2024-36844"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-36844","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-36844"}],"summary":"libmodbus v3.1.6 was discovered to contain a use-after-free via the ctx->backend pointer. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted message sent to the unit-"}