{"action":"Upgrade libmodbus to 3.1.6-2.1 or later.","affected":[{"fixed":"3.1.6-2.1","introduced":"0"}],"component":"libmodbus","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.1.6-2.1"],"id":"tcs_01M5NKM8NB72E4Z37K89PW6QD5","modified_at":"2026-11-02T12:02:34.874540218Z","published_at":"2024-05-31T20:15:10.463Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-36845","https://security-tracker.debian.org/tracker/CVE-2024-36845"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-36845#Debian:14/libmodbus","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-36845"}],"summary":"An invalid pointer in the modbus_receive() function of libmodbus v3.1.6 allows attackers to cause a Denial of Service (DoS) via a crafted message sent to the unit-test-server."}