{"action":"Upgrade node-ws to 8.18.0+~cs13.7.11-1 or later.","affected":[{"fixed":"8.18.0+~cs13.7.11-1","introduced":"0"}],"component":"node-ws","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["8.18.0+~cs13.7.11-1"],"id":"tcs_01M5NKNP8GEC9HD0R8HPKBV9DY","modified_at":"2026-09-15T09:03:06.890293551Z","published_at":"2024-06-17T20:15:13.203Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-37890","https://security-tracker.debian.org/tracker/CVE-2024-37890"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-37890#Debian:14/node-ws","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-37890"}],"summary":"ws is an open source WebSocket client and server for Node.js. A request with a number of headers exceeding theserver.maxHeadersCount threshold could be used to crash a ws server. The vulnerability was"}