{"action":"Upgrade netatalk to 3.1.18~ds-2 or later.","affected":[{"fixed":"3.1.18~ds-2","introduced":"0"}],"component":"netatalk","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.1.18~ds-2"],"id":"tcs_01M5NKNZ7HXTNQN67H2DBH4CE6","modified_at":"2026-09-15T09:03:18.844080547Z","published_at":"2024-06-16T13:15:53.147Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-38440","https://security-tracker.debian.org/tracker/CVE-2024-38440"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-38440","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-38440"}],"summary":"Netatalk before 3.2.1 has an off-by-one error, and resultant heap-based buffer overflow and segmentation violation, because of incorrectly using FPLoginExt in BN_bin2bn in etc/uams/uams_dhx_pam.c. The"}