{"action":"Upgrade node-braces to 3.0.3+~3.0.4-1 or later.","affected":[{"fixed":"3.0.3+~3.0.4-1","introduced":"0"}],"component":"node-braces","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.0.3+~3.0.4-1"],"id":"tcs_01M5NKRRFPK9N3D9DHTJVDWMS6","modified_at":"2026-09-15T09:03:08.332776154Z","published_at":"2024-05-14T15:42:48.660Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-4068","https://security-tracker.debian.org/tracker/CVE-2024-4068"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-4068#Debian:13/node-braces","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-4068"}],"summary":"The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends \"imbalance"}