{"action":"Upgrade assimp to 5.4.2+ds-1 or later.","affected":[{"fixed":"5.4.2+ds-1","introduced":"0"}],"component":"assimp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.4.2+ds-1"],"id":"tcs_01M5NKRRTQ615T93MKHYPXSHB2","modified_at":"2026-11-02T12:02:37.995385883Z","published_at":"2024-07-19T08:15:02.070Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-40724","https://security-tracker.debian.org/tracker/CVE-2024-40724"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-40724#Debian:13/assimp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-40724"}],"summary":"Heap-based buffer overflow vulnerability in Assimp versions prior to 5.4.2 allows a local attacker to execute arbitrary code by inputting a specially crafted file into the product."}