{"action":"Upgrade ruby3.3 to 3.3.5-1 or later.","affected":[{"fixed":"3.3.5-1","introduced":"0"}],"component":"ruby3.3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.3.5-1"],"id":"tcs_01M5NKVEN63Q1E3TY54S8WF0VR","modified_at":"2026-09-15T09:03:19.013521563Z","published_at":"2024-08-01T15:15:14.100Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-41946","https://security-tracker.debian.org/tracker/CVE-2024-41946"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-41946#Debian:13/ruby3.3","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-41946"}],"summary":"REXML is an XML toolkit for Ruby. The REXML gem 3.3.2 has a DoS vulnerability when it parses an XML that has many entity expansions with SAX2 or pull parser API. The REXML gem 3.3.3 or later include t"}