{"action":"Upgrade u-boot to 2025.01-3.2 or later.","affected":[{"fixed":"2025.01-3.2","introduced":"0"}],"component":"u-boot","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2025.01-3.2"],"id":"tcs_01M5NKVJE752CC348R9AC2V90V","modified_at":"2026-09-15T09:03:18.997718906Z","published_at":"2024-08-23T15:15:16.323Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-42040","https://security-tracker.debian.org/tracker/CVE-2024-42040"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-42040#Debian:14/u-boot","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-42040"}],"summary":"Buffer Overflow vulnerability in the net/bootp.c in DENEX U-Boot from its initial commit in 2002 (3861aa5) up to today on any platform allows an attacker on the local network to leak memory from four"}