{"action":"Upgrade neatvnc to 0.8.0+dfsg-2 or later.","affected":[{"fixed":"0.8.0+dfsg-2","introduced":"0"}],"component":"neatvnc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.8.0+dfsg-2"],"id":"tcs_01M5NKXTJRYRF7VXNJX4X3JZT6","modified_at":"2026-09-15T09:03:19.183772385Z","published_at":"2024-08-02T04:17:30.593Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-42458","https://security-tracker.debian.org/tracker/CVE-2024-42458"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-42458#Debian:13/neatvnc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-42458"}],"summary":"server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369."}