{"action":"Upgrade node-express to 4.21.0+~cs8.36.26-1 or later.","affected":[{"fixed":"4.21.0+~cs8.36.26-1","introduced":"0"}],"component":"node-express","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.21.0+~cs8.36.26-1"],"id":"tcs_01M5NKYJMJCEX1TRCPX6HC8BMS","modified_at":"2026-09-15T09:03:05.715315434Z","published_at":"2024-09-10T15:15:17.510Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-43796","https://security-tracker.debian.org/tracker/CVE-2024-43796"],"severity":{"label":"medium","score":4.7},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-43796#Debian:14/node-express","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-43796"}],"summary":"Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in"}