{"action":"Upgrade ruby-saml to 1.13.0-1+deb12u1 or later.","affected":[{"fixed":"1.13.0-1+deb12u1","introduced":"0"}],"component":"ruby-saml","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.13.0-1+deb12u1"],"id":"tcs_01M5NM18TM25QVAYG7C5MVZY8D","modified_at":"2026-11-04T09:47:27.334965663Z","published_at":"2024-09-10T19:15:22.030Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-45409","https://security-tracker.debian.org/tracker/CVE-2024-45409"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-45409","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-45409"}],"summary":"The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthentic"}