{"action":"Upgrade expat to 2.5.0-1+deb12u1 or later.","affected":[{"fixed":"2.5.0-1+deb12u1","introduced":"0"}],"component":"expat","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.5.0-1+deb12u1"],"id":"tcs_01M5NM19A7ZQF3N6NPNVS4X7CM","modified_at":"2026-11-02T12:02:49.267001856Z","published_at":"2024-08-30T03:15:03.757Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-45490","https://security-tracker.debian.org/tracker/CVE-2024-45490"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-45490","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-45490"}],"summary":"An issue was discovered in libexpat before 2.6.3. xmlparse.c does not reject a negative length for XML_ParseBuffer."}