{"action":"Upgrade haproxy to 2.9.10-1 or later.","affected":[{"fixed":"2.9.10-1","introduced":"0"}],"component":"haproxy","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.9.10-1"],"id":"tcs_01M5NM1AVRYFNZ8GG93C6X3NA6","modified_at":"2026-09-15T09:03:19.407984183Z","published_at":"2024-09-04T15:15:14.080Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-45506","https://security-tracker.debian.org/tracker/CVE-2024-45506"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-45506#Debian:14/haproxy","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-45506"}],"summary":"HAProxy 2.9.x before 2.9.10, 3.0.x before 3.0.4, and 3.1.x through 3.1-dev6 allows a remote denial of service for HTTP/2 zero-copy forwarding (h2_send loop) under a certain set of conditions, as explo"}