{"action":"Upgrade assimp to 5.4.0+ds-1 or later.","affected":[{"fixed":"5.4.0+ds-1","introduced":"0"}],"component":"assimp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.4.0+ds-1"],"id":"tcs_01M5NM1GMQMPSHY3C7J6PMTCCW","modified_at":"2026-11-02T12:02:49.193318487Z","published_at":"2024-09-18T04:15:42.080Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-45679","https://security-tracker.debian.org/tracker/CVE-2024-45679"],"severity":{"label":"high","score":8.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-45679#Debian:14/assimp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-45679"}],"summary":"Heap-based buffer overflow vulnerability in Assimp versions prior to 5.4.3 allows a local attacker to execute arbitrary code by importing a specially crafted file into the product."}