{"action":"Upgrade requests to 2.32.4+dfsg-1 or later.","affected":[{"fixed":"2.32.4+dfsg-1","introduced":"0"}],"component":"requests","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.32.4+dfsg-1"],"id":"tcs_01M5NM45GMMDHC3FY7MS72E1ME","modified_at":"2026-09-15T09:03:10.269633418Z","published_at":"2025-06-09T18:15:24.983Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-47081","https://security-tracker.debian.org/tracker/CVE-2024-47081"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-47081#Debian:14/requests","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-47081"}],"summary":"Requests is a HTTP library. Due to a URL parsing issue, Requests releases prior to 2.32.4 may leak .netrc credentials to third parties for specific maliciously-crafted URLs. Users should upgrade to ve"}