{"action":"Upgrade needrestart to 3.7-3.1 or later.","affected":[{"fixed":"3.7-3.1","introduced":"0"}],"component":"needrestart","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.7-3.1"],"id":"tcs_01M5NM6E7M3CBW3SFR58H6F08P","modified_at":"2026-11-02T12:03:03.881480039Z","published_at":"2024-11-19T18:15:21.897Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-48992","https://security-tracker.debian.org/tracker/CVE-2024-48992"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-48992#Debian:13/needrestart","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-48992"}],"summary":"Qualys discovered that needrestart, before version 3.8, allows local attackers to execute arbitrary code as root by tricking needrestart into running the Ruby interpreter with an attacker-controlled R"}