{"action":"Upgrade haproxy to 2.9.11-1 or later.","affected":[{"fixed":"2.9.11-1","introduced":"0"}],"component":"haproxy","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.9.11-1"],"id":"tcs_01M5NM6EZD1HZXPDSG056V64T2","modified_at":"2026-11-02T12:02:53.070158124Z","published_at":"2024-10-14T04:15:05.853Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-49214","https://security-tracker.debian.org/tracker/CVE-2024-49214"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-49214#Debian:14/haproxy","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-49214"}],"summary":"QUIC in HAProxy 3.1.x before 3.1-dev7, 3.0.x before 3.0.5, and 2.9.x before 2.9.11 allows opening a 0-RTT session with a spoofed IP address. This can bypass the IP allow/block list functionality."}