{"action":"Upgrade gh to 2.46.0-2 or later.","affected":[{"fixed":"2.46.0-2","introduced":"0"}],"component":"gh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.46.0-2"],"id":"tcs_01M5NMBWC552K7DDY1N1BSXBJW","modified_at":"2026-09-15T09:03:14.607894874Z","published_at":"2024-11-14T23:15:05.727Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-52308","https://security-tracker.debian.org/tracker/CVE-2024-52308"],"severity":{"label":"critical","score":9.6},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-52308#Debian:13/gh","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-52308"}],"summary":"The GitHub CLI version 2.6.1 and earlier are vulnerable to remote code execution through a malicious codespace SSH server when using `gh codespace ssh` or `gh codespace logs` commands. This has been p"}