{"action":"Upgrade glib2.0 to 2.82.1-1 or later.","affected":[{"fixed":"2.82.1-1","introduced":"0"}],"component":"glib2.0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.82.1-1"],"id":"tcs_01M5NMC1MN8BYQFXTMGYZ847HD","modified_at":"2026-10-15T09:47:38.320689791Z","published_at":"2024-11-11T23:15:05.967Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-52533","https://security-tracker.debian.org/tracker/CVE-2024-52533"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-52533#Debian:14/glib2.0","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-52533"}],"summary":"gio/gsocks4aproxy.c in GNOME GLib before 2.82.1 has an off-by-one error and resultant buffer overflow because SOCKS4_CONN_MSG_LEN is not sufficient for a trailing '\\0' character."}