{"action":"Upgrade node-prismjs to 1.30.0+dfsg+~1.26.5-1 or later.","affected":[{"fixed":"1.30.0+dfsg+~1.26.5-1","introduced":"0"}],"component":"node-prismjs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.30.0+dfsg+~1.26.5-1"],"id":"tcs_01M5NMEDHKKX0JJQHA4B45M38S","modified_at":"2026-11-02T12:03:09.501347508Z","published_at":"2025-03-03T07:15:33.397Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-53382","https://security-tracker.debian.org/tracker/CVE-2024-53382"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-53382#Debian:14/node-prismjs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-53382"}],"summary":"Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can"}