{"action":"Upgrade editorconfig-core to 0.12.7-0.1 or later.","affected":[{"fixed":"0.12.7-0.1","introduced":"0"}],"component":"editorconfig-core","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.12.7-0.1"],"id":"tcs_01M5NMEJP9CC1DN8PR31S3ZYH5","modified_at":"2026-09-15T09:03:15.328587877Z","published_at":"2024-11-27T00:15:18.223Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-53849","https://security-tracker.debian.org/tracker/CVE-2024-53849"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-53849#Debian:14/editorconfig-core","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-53849"}],"summary":"editorconfig-core-c is theEditorConfig core library written in C (for use by plugins supporting EditorConfig parsing). In affected versions several overflows may occur in switch case '[' when the inpu"}