{"action":"Upgrade rust-pgp to 0.14.2-1 or later.","affected":[{"fixed":"0.14.2-1","introduced":"0"}],"component":"rust-pgp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.14.2-1"],"id":"tcs_01M5NMEJT0DYMAFSEWP8BPSPC9","modified_at":"2026-09-15T09:03:15.287978208Z","published_at":"2024-12-05T16:15:26.237Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-53856","https://security-tracker.debian.org/tracker/CVE-2024-53856"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-53856","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-53856"}],"summary":"rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1."}